//
you're reading...

Featured

Windows 7 firewall service won’t start

Problem

When you attempt to start the Windows 7 firewall service you receive the following error

Windows could not start the Windows Firewall on Local Computer. For more information, review the system event log. If this is a non-Microsoft service, contact the service vendor, and refer to service-specific error code 5.

If you look in the System Event Log, you will see event 7024 from the Service Control Manager

The Windows Firewall service terminated with service-specific error Access is denied..

Cause

This may be caused because the “NT Service\MpsSvc” account does not have adequate permissions on the following registry key

HKLM\SYSTEM\CurrentControlSet\Services\SharedAccess

Solution

  1. In Registry Editor, browse to the key HKLM\SYSTEM\CurrentControlSet\Services\SharedAccess
  2. Right click SharedAccess, and click Permissions.
  3. Click Add.
  4. In the “Enter the object names to select” field, type “NT SERVICE\mpssvc”. Then click Check Names. The name should change to MpsSvc
  5. Click OK.
  6. Select Full Control in the Allow column.
  7. Click OK.

Applies To

Windows 7 (all versions) / Windows Vista (all versions)

Be Sociable, Share!

Discussion

86 Responses to “Windows 7 firewall service won’t start”

  1. Thanks, it worked!!

    Posted by Don | February 9, 2013, 2:55 am
  2. thanks man , all over the web none was good and direct like you :)

    Posted by yoel | February 13, 2013, 1:09 pm
  3. yes.work it for win 7 64 bit .
    only only this solution worked
    tnx :mrgreen:

    Posted by behnam | February 15, 2013, 1:33 pm
  4. Thank you very much.

    Posted by Thankful PC owner | February 17, 2013, 11:03 pm
  5. Looked everywhere – then found this – brilliant direct to the point and works perfectly ,

    THANKYOU

    Posted by saint | February 27, 2013, 4:50 am
  6. Wow. Looked far and wide. This worked GREAT!

    Posted by Awesome Solution | March 13, 2013, 6:40 pm
  7. Love ya man!!

    Posted by bigT | March 17, 2013, 10:39 am
  8. OMG it worked!!! After looking and trying all types of permissions this one did it :wink:

    Posted by Reyna | March 29, 2013, 1:12 am
  9. your solutions rock!! I spent days on microsoft site (communinities, forums, etc) to get my firewall fixed.. had multiple problems and you got answers for all of them. thank you so much.
    Microsoft should learn from you!!!

    thank you again.

    Posted by sniper | March 29, 2013, 9:33 pm
  10. Wow I had tried a million different things including hot fixes, reg changes, checking services permissions, etc…this was the trick thanks a million :lol:

    Posted by PCGEEK | April 9, 2013, 8:57 pm
  11. Awesome it worked!!!!

    Posted by Jason | April 15, 2013, 4:28 pm
  12. i had try the way u post, it still can not b work. still got any other sulotion?

    Posted by soo | April 29, 2013, 7:55 am
  13. Tried a dozen other fixes. None worked.
    This one DID work.
    Thanks.

    Posted by tekwildcat | May 2, 2013, 11:05 am
  14. Wow i had try now its working fine.

    Thank a lot :lol:

    Posted by Pradeepsinh | May 14, 2013, 2:35 am
  15. OMG, I looked through so many threads and so many other sites to try to fix this bitch. Thank you so much bro. It was so much easier than all the other people made it out to be.

    Posted by Alexxx | May 26, 2013, 3:57 pm
  16. Just had to leave a comment to say that this worked!

    Posted by push3r | May 29, 2013, 6:34 pm
  17. it didnt work on windows 8 32bit

    Posted by victor | June 1, 2013, 6:26 am
  18. Worked for me, too. Trouble arose after removal of Internet Security 2013 virus. Firewall service initially did not even appear in Services. Got them back but firewall service would not start. This fixed after a few hours of searching for the cure.
    THANKS!

    Posted by Orwiz | June 1, 2013, 8:10 am
  19. Merci énormément

    Enfin une solution brillante

    Posted by André | June 21, 2013, 7:48 pm
  20. Thank you, it was really helpful. It fixed the issue for me

    Posted by Rodger | June 24, 2013, 4:24 pm
  21. After everything I had tried this was the ONLY solution that worked and it also fixed the, Function Discovery Resource Publication service – Access Denied error, I was getting aswell. Thankyou! :mrgreen:

    Posted by Success!! | June 30, 2013, 6:13 pm
  22. Worked for me….Thank you

    Posted by vinoth | July 2, 2013, 3:12 am
  23. Perfect! Spent hours trying other solutions, yours is the only one that worked – the first time. I’ve saved this for future reference. Thank you.

    Posted by Jim Davis | August 3, 2013, 3:35 pm
  24. After doing this i got service code error-13

    Posted by Bala | August 15, 2013, 7:41 am
  25. :razz: :razz: :razz: :razz:
    WONDERFUL, thank you, you described my EXACT problem and it worked!!!

    Posted by pat | August 18, 2013, 5:55 pm
  26. yeah..thanks dude

    Posted by single | August 23, 2013, 9:54 am
  27. thats work thanks alot

    Posted by USMAN YAHYA | October 26, 2013, 12:58 pm
  28. Thank you, it’s works for me.

    Thank a lot Mr Kent Oyer.

    Posted by HCR | December 26, 2013, 5:49 pm
  29. It Worked!
    and all of the microsoft support was bullshit!
    Thank you Guys!

    Posted by Em | January 1, 2014, 4:00 am
  30. Thank you SOOOOO Much!!!! It Worked

    Posted by Reginald Jennings | January 10, 2014, 10:52 am
  31. I can’t figure for the life of me how my service got turned off, but your solution had it fixed in less than 1 minute..YOU DA’ MAN..:)

    Posted by C Blunk | January 20, 2014, 2:38 am
  32. Oh my goodness! Thank you SO MUCH KEN. I just spent most of my extra day off searching and trying dozens of different fixes to this firewall error in Vista. !!@#$%

    And somehow, thankfully, I came across your site! I wish I had found this sooner, because it fixed it right away, and with nicely done instructions! Thanks again!

    Posted by Shari Thompson | January 20, 2014, 7:37 pm
  33. Thank you thank you thank you… looked all over the web for a solution that wasn’t convoluted and over complicated – instinct told me it should be something simple – full credit to you!

    Posted by Mellie | January 31, 2014, 6:09 am
  34. It works.
    Thank you So Much…. (y)

    Posted by Antonius | March 26, 2014, 8:30 pm
  35. Thank you!!! I tried Microsoft’s automated tool for this, no luck, followed their manual steps, no luck, and your solutions worked instantly!

    Posted by Lianne Lavoie | April 12, 2014, 12:18 pm

Trackbacks/Pingbacks

  1. […] Full props go to this website where I found the solution – http://www.kentoyer.com/2012/01/15/windows-7-firewall-service-wont-start/ […]

Post a Comment